Page 1 sur 1

esxi et dge-528t

Publié : sam. 1 févr. 2020 12:47
par manu7577
Bonjour a tous,

Je souhaite ajouter une carte réseau sur mon esxi (6.5U3).
C'est une D-Link DGE-528T.
J'ai trouvé le vib et l'ai installé, mais la carte réseau n’apparaît pas lorsque j'execute la commande "esxcfg-nics -l" (et n’apparaît pas non plus dans la console graphique").
Pourtant la carte réseau apparaît lorsque j’exécute la commande "lspci -v | grep Net".
J'ai redémarre le serveur après l'instal.

Je ne vois pas ce qui bloque.

Si des personnes plus douées que moi sur esxi ont une idée, je suis preneur ;)

Re: esxi et dge-528t

Publié : sam. 1 févr. 2020 15:47
par poulpito
pas le bon driver vs l'ESX ou vib mal installé je pense

il te dit bien que l'install est OK ?
dans la doc du vib y'a rien d'autre à faire comme activer un module ?

Re: esxi et dge-528t

Publié : sam. 1 févr. 2020 16:15
par manu7577
J'ai que le vib, pas d'autre fichiers.
Pour l'instal, j'ai un message :
[DependencyError]
VIB DLink_bootbank_DLink-528T_1 requires vmkapi_2_0_0_0, but the requirement cannot be satisfied within the ImageProfile.
VIB DLink_bootbank_DLink-528T_1 requires com.vmware.driverAPI-9.2.0.0, but the requirement cannot be satisfied within the ImageProfile.

J'ai forcé l'instal avec -f

Re: esxi et dge-528t

Publié : sam. 1 févr. 2020 16:31
par poulpito
https://aubreykloppers.wordpress.com/20 ... nd-driver/ ?

et sinon apparemment drivers trop vieux (5.1 pas plus) les gens ont eu les même log en upgradant 5 > 6
va falloir changer de carte :/
tu as un slot pci ou un slot PCI-X ? si tu as du pci-x je peux t'envoyer une 4x1G IBM

Re: esxi et dge-528t

Publié : sam. 1 févr. 2020 16:56
par manu7577
le site d'Aubrey, c'est celui que j'ai suivi

Re: esxi et dge-528t

Publié : sam. 1 févr. 2020 17:17
par manu7577
Je n'ai pas obligatoirement besoin de 4 ports LAN : tout est virtuel dans mon infra, cette 2e carte est juste pour permettre a mon pc portable de se connecter au vswitch.

Combien la vendrais-tu (port in) ?
Je garde ta proposition en tete.

Re: esxi et dge-528t

Publié : sam. 1 févr. 2020 19:46
par poulpito
ah non si c'est du pci-x je te la donne ;) elle peut partir lundi aprem au besoin (cherche IBM 03N5444 sur google image c'est les mêmes que ca)
je sais pas sic 'est supporté sur les esxi récents mais dans le doute voila ca coute rien

Si ca marche contre ce que tu veux pour boire une bière :D

Re: esxi et dge-528t

Publié : dim. 2 févr. 2020 08:36
par manu7577
En esxi 6.5 u1 ou u2, je sais plus, 1 seule carte réseau reliée au vswitch me suffisait pour les 2 pattes de mon pfsense. J'arrivais a le paramétrer et ça roulait.
Maintenant, tous les flux veulent passer par la patte wan... pfff !!!!
J'ai testé avec une intel 4 ports giga pci express (je connais pas le modèle mais la puce c'est LFE9219C-R), mon serveur ne démarre pas.
J'ai testé traiter 8139 sans succès (bon je m'en doutait), et j'ai testé une DFE-530tx, sans succès non plus.

Re: esxi et dge-528t

Publié : dim. 2 févr. 2020 08:41
par manu7577
J'ai un port pci 32, un port pciex16 et un port pciex1 de libre.

Re: esxi et dge-528t

Publié : dim. 2 févr. 2020 08:59
par dsebire
Salut,

si t'es en esxi6.5, ce package pourrait passer pour la Dlink: https://vibsdepot.v-front.de/wiki/index.php/Net51-r8169
il ne fonctionne pas en esxi6.7

Re: esxi et dge-528t

Publié : dim. 2 févr. 2020 09:04
par manu7577
J'ai installé le net55.
Je vais tester le net51.

Re: esxi et dge-528t

Publié : dim. 2 févr. 2020 09:13
par manu7577
J'ai le même message d'erreur : dependencyerror

Re: esxi et dge-528t

Publié : dim. 2 févr. 2020 09:31
par manu7577
Sympa : j'ai desinstalle le vib DLink 528T, j'ai pu installer le net51.
Je suis en train d'installer le net55.
Apres j'eteint l'esxi, installe le carte et redemarre puis test.

Re: esxi et dge-528t

Publié : dim. 2 févr. 2020 09:46
par manu7577
Apres reboot de l'esxi, la D-Link DGE-528T n'est pas reconnue.
Je vais tester avec la dfe-530

Re: esxi et dge-528t

Publié : dim. 2 févr. 2020 09:56
par manu7577
pas mieux :(

Re: esxi et dge-528t

Publié : lun. 3 févr. 2020 14:38
par manu7577
poulpito a écrit :
sam. 1 févr. 2020 19:46
ah non si c'est du pci-x je te la donne ;) elle peut partir lundi aprem au besoin (cherche IBM 03N5444 sur google image c'est les mêmes que ca)
je sais pas sic 'est supporté sur les esxi récents mais dans le doute voila ca coute rien

Si ca marche contre ce que tu veux pour boire une bière :D
Si toujours ok pour la carte, je suis preneur.
Si nous étions plus proche, je t'aurais payé un coup :D

Re: esxi et dge-528t

Publié : lun. 3 févr. 2020 17:32
par poulpito
euh pas 100% dit qu'elle passe sur un port PCI32 surtout si tu as des composants derrière ein ?
c'est une carte PCI-X ^^ pas pcie ni pci :D

si t'es sur pas de soucis (de mémoire elle marche sur un pci mais vitesse réduite en tout cas pas 4x1G)
tu me met ton adresse en mp et ca part dès que possible jte laisserai mon adresse dessus ;)

Re: esxi et dge-528t

Publié : mer. 5 févr. 2020 14:22
par manu7577
Ok Poulpito (désolé de ma réponse tardive).
J'ai 2 ou 3 port PCI32, je verrais pour déplacer une carte SCSI.

Je te fais un MP.

Re: esxi et dge-528t

Publié : ven. 7 févr. 2020 13:22
par manu7577
Poulpito,
As-tu le modèle de la carte que tu souhaite m'envoyer que je commence a regarder pour le vib ?

Re: esxi et dge-528t

Publié : ven. 7 févr. 2020 14:26
par poulpito
normallement tu aura pas besoin de vib
je t'ai trouvé mieux que la IBM .. bon toujours en PCI-X mais bien compatible PCI32 (vu qu'elle a l'encoche séparée)
une HP NC7170
https://www.vmware.com/resources/compat ... ductid=609

Re: esxi et dge-528t

Publié : jeu. 13 févr. 2020 11:53
par manu7577
Bon, pour installer la carte fournit par Poulpito, j'ai retiré une adaptec 39120.
Comme il me reste un port PCI Express de libre, j'y ai mis une Perc5/i... (j'ai un 72Go SAS que m'avait donné dsebire, et un 300Go SAS pour le moment… mais surement un peu plus dans pas longtemps).

Pour que la PERC soit reconnue, j'ai du refaire mon ESXi en 6.0U3.

Mais bon, après, il est équipé de manière sympathique.

Re: esxi et dge-528t

Publié : sam. 15 févr. 2020 10:36
par manu7577
Ben ca y est, mon esxi fonctionne avec la carte de Poulpito ;)