Débits HDD/SSD/SATA/NVMe/PCIe

Répondre
Avatar de l’utilisateur
Ryu_wm
Messages : 5857
Inscription : ven. 12 janv. 2018 17:44
Localisation : Pont l'Abbé d'Arnoult (17)

Débits HDD/SSD/SATA/NVMe/PCIe

Message par Ryu_wm »

Bonjour.

Suite de mes recherches pour obtenir des débits importants R/W sur un disque système, dernier épisode pas glorieux viewtopic.php?f=1&t=9186

Ce jour, tests réalisés sur carte mère Gigabyte Z370 HD3 https://www.gigabyte.com/fr/Motherboard/Z370-HD3-rev-10
C'est une cm d'entrée de gamme avec peu d'options, mais au moins elle embarque un port NVMe.

Comme je viens de récupérer un NVMe B+M WD 256Go Image
je vais procéder à la comparaison avec ce qui est déjà sur ce système, à savoir :

OS sur SSD Kingston 240Go SA40037240G. Image
qui est donc sur un port SATA de la cm.

Données sur SSHD Seagate 3To ST3000md007 Image

et pour finir un NVMe B+M Micron 256Go sur la carte PCIe en premier lien, mais en passant par le port SATA et non pas PCIe.

Tests de débits réalisés avec CrystalMark64 https://crystalmark.info/en/software/crystaldiskmark/

Résultats :
Image

Sans surprise le disque méca de 3To est le plus lent.
Ensuite vient le SSD Kingston, en comparaison sur le même bus SATA le NVMe Micron fait bien mieux.
Sans surprise le NVMe embarqué sur la cm qui lui utilise le bus PCIe est bien plus rapide que tous les autres.


J'en ai profité pour cloner le Kingston sur le Western Digital mais comme le boot manager Win10 est sur le méca Seagate, et bien ça ne boote pas.
Je suis en train de manipuler bcdedit mais je sens que ça va se terminer en catastrophe. Bien évidemment je n'ai pas de clé USB de plus de 4Go pour faire un ISO d'install de W10 afin de manipuler le bootmanager, donc ça attendra une prochaine fois. Mais j'ai hâte de sentir comment se comporte le système depuis le Western Digital.
Avatar de l’utilisateur
Ryu_wm
Messages : 5857
Inscription : ven. 12 janv. 2018 17:44
Localisation : Pont l'Abbé d'Arnoult (17)

Re: Débits HDD/SSD/SATA/NVMe/PCIe

Message par Ryu_wm »

ça m'énervait. J'ai trouvé une vieille SDcard, mise dans un adaptateur USB et j'ai mis un disque amorçable de Win10 dessus.
Amorcer avec le hdd méca connecté, le NVMe connecté et le SSD déconnecté.
Plutôt que d'installer une version demander à réparer, outils de réparation, lignes de commande

bootrec /scanos -> trouve la partition Win10 sur le NVMe
bootrec /fixmbr
bootrec /rebuildbcd ->demande si on veut ajouter la partirion Win10 trouvée dans la liste de démarrage

et reboot

et : superbe, ça démarre en , 4 secondes ?
Avatar de l’utilisateur
jsonline_bis
Messages : 41
Inscription : mer. 20 mars 2019 09:48

Re: Débits HDD/SSD/SATA/NVMe/PCIe

Message par jsonline_bis »

DISQUE | Taille (Go) | LECTURE (MB/s)| ECRITURE (MB/s) | (données test, en MB)

NVME 760P | 256 | 2518 | 1236 | crystaldisk 1G, 0 fill

M2 MX500 | 931 | 560 | 560 | crystaldisk 1G, 0 fill

NVME 600P | 238 | 720 | 490 | avec dd if=/dev/zero of=/tmp/test.data bs=1M count=1024 conv=fdatasync

M2 840PRO | 119 | 516 | 296 | avec dd if=/dev/zero of=/media/win_c2/test.data bs=1M count=1024 conv=fdatasync

DS916+ Raid 5 | total=7168 | NA | 722 | avec dd if=/dev/zero of=tempfile bs=1M count=1024

les disques 1 et 2 sont dans 1 PC , les 3 et 4 dans un deuxieme.
Le raid 5 du DS916+ c'est 2x4 To et 1x6 To

J'ai un autre raid 5 avec une carte LSI dont faudrait que je teste les debits, mais l'ordi est pas allumé là. (J'en avais parlé là bas : viewtopic.php?f=1&t=9034&p=323595&hilit=LSI#p323595 . Ce raid là est BTRFS, comme mon NAS. J'avais hésité avec ZFS mais au final j'ai préféré pas avoir trop de systèmes de fichiers différents. Pour le système c'est toujours Opensuse, toujours pas changé pour une distrib NAS cet ordi là, ce que j'avais envisagé pourtant. Son raid 5 doit être plus rapide que le NAS normalement car c'est du 7200 tours alors que le NAS c'est du 5400.
Avatar de l’utilisateur
Larifounette
Messages : 6550
Inscription : ven. 12 janv. 2018 17:44
Localisation : Maine et Loire

Re: Débits HDD/SSD/SATA/NVMe/PCIe

Message par Larifounette »

Sinon, sur un ram drive, sa donne sa :

Image
Avatar de l’utilisateur
biour
Messages : 19979
Inscription : ven. 12 janv. 2018 17:44

Re: Débits HDD/SSD/SATA/NVMe/PCIe

Message par biour »

Coucou Lari !!!
Comment vas?
Image
Avatar de l’utilisateur
Larifounette
Messages : 6550
Inscription : ven. 12 janv. 2018 17:44
Localisation : Maine et Loire

Re: Débits HDD/SSD/SATA/NVMe/PCIe

Message par Larifounette »

biour a écrit : lun. 17 mai 2021 17:55 Coucou Lari !!!
Comment vas?
:hello:
Avatar de l’utilisateur
Ryu_wm
Messages : 5857
Inscription : ven. 12 janv. 2018 17:44
Localisation : Pont l'Abbé d'Arnoult (17)

Re: Débits HDD/SSD/SATA/NVMe/PCIe

Message par Ryu_wm »

un Ramdrive sous Windows, merci de m'indiquer ce que tu utilise ça m'intéresse :jap:
Avatar de l’utilisateur
Larifounette
Messages : 6550
Inscription : ven. 12 janv. 2018 17:44
Localisation : Maine et Loire

Re: Débits HDD/SSD/SATA/NVMe/PCIe

Message par Larifounette »

Heuuu, je crois que je l'ai fait avec sa : https://www.google.com/amp/s/overclocki ... g-ramdisk/
Avatar de l’utilisateur
X-System
Messages : 6371
Inscription : ven. 12 janv. 2018 17:44

Re: Débits HDD/SSD/SATA/NVMe/PCIe

Message par X-System »

Ryu_wm, ton Kingston 240Go SSD, quel est son état ? Ce n'est pas normal que sa performance d'écriture soit moins de 30 Mo/s.
PC1 = MW70-3S0 # 2x E5-2667 v3 # 32Go DDR4 ECC reg 2133 # RTX 3080 Ti # 2x1Go SSD
PC2 = Z170XP-SLI # i7-7700 # 16Go DDR4 2400 # 240Go NVMe # SAS9211-8i # 8 SSD/HDD SATA # LTO-5 SAS
PC3 = T61p # T9500 # 4Go DDR2 667 # FX570m # 120Go SSD
Avatar de l’utilisateur
Ryu_wm
Messages : 5857
Inscription : ven. 12 janv. 2018 17:44
Localisation : Pont l'Abbé d'Arnoult (17)

Re: Débits HDD/SSD/SATA/NVMe/PCIe

Message par Ryu_wm »

:hello:
Plus d'infos disponibles, je l'ai remplacé par le NVMe.

D'ailleurs en clonant j'ai perdu de l'espace disque, m'en étais pas aperçu :p

Image
Répondre