Problème d'installation de Windows XP

Envie de tchacher, n'hésitez pas !
Répondre
levend
Messages : 7833
Inscription : ven. 12 janv. 2018 17:44

Problème d'installation de Windows XP

Message par levend »

Bonsoir,
J'ai récemment acheté un PC ancien pour mettre sur ma CNC, malheureusement il me faut installer Windows XP dessus (peut-être que Vista pourrait fonction, il doit encore gérer le port parallèle mais n'est pas dans la liste des OS accepté), j'ai réussi à obtenir une iso d'un CD de Windows XP SP3.
J'ai voulut le graver mais j'ai des soucis de gravure avec un lecteur/graveur USB juste sorti de son emballage, on m'a conseillé de créer une clé USB bootable, c'est ce que j'ai fait après avoir sauvegardé tout son contenu.

Lorsque j'ai booté le PC sur la clé USB il démarre bien l'installation de XP mais quelques seconde après j'ai eu au belle écran bleu (vous vous souvenez de cet écran ? :D ), je n'ai pas retenté.
J'avais déjà essayé d'installer Windows 2000 dont j'ai encore le CD avec la licence et j'avais aussi eu le droit à ce bel écran bleu et après plusieurs tentative je m'étais dit que c'était parce que voulais installer une version trop vieille de Windows et j'ai commencé à chercher une version d'XP.

Le PC fonctionne, je l'ai essayé avec un disque dur sur lequel était installé Windows 7 et il a booté sans problème, j'ai juste ouvert Windows et peut-être une application pour vérifier que ça fonctionnait puis j'ai tout arrêté et retiré le dd avec W7.

Je ne sais plus quoi faire et j'ai besoin de ce PC pour ma CNC qui devrait tourner tous les jours en ce moment pour rattraper le retard que j'ai pris depuis que le premier PC est tombé en panne.
L'ancien PC (avec XP Pro) ne fait que biper a démarrage et je n'ai pas réussi à en trouver la raison.

Avatar de l’utilisateur
Ryu_wm
Messages : 5441
Inscription : ven. 12 janv. 2018 17:44
Localisation : Pont l'Abbé d'Arnoult (17)

Re: Problème d'installation de Windows XP

Message par Ryu_wm »

Hello,
le temps des installs de Win XP n'étant pas si loin pour moi je peux essayer de t'aider mais il me faut des indices.

WinXP peut s'installer depuis une clé USB c'est indéniable mais cela dépend du matos.
Ce qui m'étonne c'est que tu aies un écran bleu avec 2K et XP cela démontre un schéma de panne.
J'aimerai bien avoir le code d'erreur de l'écran bleu ...

Saches que tu peux toujours lancer l'install d'XP depuis un autre PC et la poursuivre sur ton PC problématique après (processus de partitionnement + copie des fichiers sur PC A puis déplacement du disque dur et boot sur celui-ci depuis PC B pour lancement de la séquence d'installation).

Bref dis m'en plus.

//Edit, un descriptif du matos ça serait bien aussi.

arank-thnar
Messages : 4042
Inscription : ven. 12 janv. 2018 17:44

Re: Problème d'installation de Windows XP

Message par arank-thnar »

Je dirais disque dur HS.
En gros quand tu arrives à un certain point du chargement, il plante.
Essaie de changer de disque dur.
Tu peux y mettre du SATA ? Ou c'est du IDE ?
J'ai peut être de quoi te dépanner. Mais j'ai peur pour le transport ...

:/

levend
Messages : 7833
Inscription : ven. 12 janv. 2018 17:44

Re: Problème d'installation de Windows XP

Message par levend »

La config : dell optiplex 780 avec du core 2 duo e8500.
Désolé je n'ai pas relevé le code d'erreur.

Je n'ai pas essayé avec un autre disque dur, je n'y ai pas pensé mais c'est peut-être une histoire de Bios
La machine a servi de test, donc le 2003 ne m’étonne pas, l'autre disque était celui d’origine, mais comme le bios a du être modifié (sata IDE ou AHCI...),
J'ai commencé à regardé ça hier soir mais je n'ai rien vu d'anormal.

Edit : Les disques sont en SATA.

arank-thnar
Messages : 4042
Inscription : ven. 12 janv. 2018 17:44

Re: Problème d'installation de Windows XP

Message par arank-thnar »

Franchement, si en plus c'est du sata, tente avec un autre HDD.
Ca enlèvera une cause éventuelle.

Albat!
Messages : 49
Inscription : mar. 2 juil. 2019 13:30

Re: Problème d'installation de Windows XP

Message par Albat! »

Salut,

Attention au mode AHCI non pris en charge par windows XP mais seulement à partir de Vista, de vieille mémoire il ne trouvait pas le disque dur dans ce mode, mais peut-être qu'il provoque des écrans bleus.

gizmo78
Messages : 16807
Inscription : ven. 12 janv. 2018 17:44

Re: Problème d'installation de Windows XP

Message par gizmo78 »

+1 il fallait ajouter un driver au début de l'installe

dsebire
Messages : 10410
Inscription : ven. 12 janv. 2018 17:44
Localisation : Loiret - au milieu des champs

Re: Problème d'installation de Windows XP

Message par dsebire »

ou repasser le contrôleur en legacy IDE dans le BIOS (toutes les "vieilles" CM proposent ça)

Albat!
Messages : 49
Inscription : mar. 2 juil. 2019 13:30

Re: Problème d'installation de Windows XP

Message par Albat! »

D'ailleurs c'est bien ça, ça provoque un BSOD https://www.commentcamarche.net/forum/a ... -avec-ahci

Le mieux comme dit dsebire c'est de repasser en IDE/Legacy, sur windows XP l'AHCI n'apporte pas grand chose (quand il est exploitable) de mémoire.

https://support.microsoft.com/fr-fr/hel ... boot-drive

Avatar de l’utilisateur
Ryu_wm
Messages : 5441
Inscription : ven. 12 janv. 2018 17:44
Localisation : Pont l'Abbé d'Arnoult (17)

Re: Problème d'installation de Windows XP

Message par Ryu_wm »

vous confondez pas Legacy/UEFI avec AHCI/ATA des fois ?
'fin bref pas d'AHCI sous XP sauf si pilotes spécifiques.

J'ai des Optiplex 360 et 755 qui tournaient en AHCI sous XP ceci dit, voir chez DELL pilotes, mais 1° ça n'apporte rien, et 2° le jour où tu change par mégarde entre AHCI et ATA là tu as ze panne et tu peux même casser l'OS.

levend
Messages : 7833
Inscription : ven. 12 janv. 2018 17:44

Re: Problème d'installation de Windows XP

Message par levend »

J'ai essayé de repassé en "Legacy" mais le résultat est toujours le même. C'est sûrement à cause de ça que j'ai toujours monté mes propres PCs et jamais acheté de PC de marque, ça fonctionnait :D .

Étrangement ce soir j'ai ré-essayé le premier PC que j'avais acheté pour ma machine et il a démarré alors que je ne lui ai rien fait et au bout d'environs 1 minute il s'est arrêté sans que j'y touche. Je crois que la chance n'est plus avec moi.

Je fais une dernière tentative en remontant un PC à partir des vieux composant qu'il me reste et si ça fonctionne tant mieux, sinon j'abandonne.
Là que j'ai du temps pour faire ce que j'ai à faire avec ma machine et que j'ai la matière première c'est l'informatique qui déconne...

Edit : il y a au moins deux mois que je n'ai plus de PC pour cette machine.

gizmo78
Messages : 16807
Inscription : ven. 12 janv. 2018 17:44

Re: Problème d'installation de Windows XP

Message par gizmo78 »

fait un reset bios, regarde si c'est bien en ide et réessaye une installation propre.

arank-thnar
Messages : 4042
Inscription : ven. 12 janv. 2018 17:44

Re: Problème d'installation de Windows XP

Message par arank-thnar »

Roohh
Tu vas bien y arriver.
Je m'en suis bien sorti avec mon histoire. :lol:

Et j'ai même réussi à finaliser la réinstall' d'un HP G62. Hyper compliqué de trouver le bon driver graphique!
J'ai aussi réussi à ressusciter une vieille imprimante laser HP sur Win10 !

Allez persévère !

levend
Messages : 7833
Inscription : ven. 12 janv. 2018 17:44

Re: Problème d'installation de Windows XP

Message par levend »

J'ai abandonné.
Je regarde pour remonter une vieille config perso, aujourd'hui j'ai passé du temps en mode "archéologue" :D et j'ai retrouvé pas mal de chose dont ce qu'il me manquait jusque là : une carte graphique (qui devrait fonctionner) mais je peut faire mieux, j'ai une config plus récente et complète que je n'arrive pas à retrouver.
Mais alors j'ai un tas de choses de stocké dans différents endroit, je pense que je vais devoir faire du vide d'ici quelques temps.

Avatar de l’utilisateur
Ryu_wm
Messages : 5441
Inscription : ven. 12 janv. 2018 17:44
Localisation : Pont l'Abbé d'Arnoult (17)

Re: Problème d'installation de Windows XP

Message par Ryu_wm »

Sinon j'ai un Dell Optiplex 755 sous XP qui part à la benne sous peu :lol:

arank-thnar
Messages : 4042
Inscription : ven. 12 janv. 2018 17:44

Re: Problème d'installation de Windows XP

Message par arank-thnar »

Le souci va être de lui envoyer. :o

levend
Messages : 7833
Inscription : ven. 12 janv. 2018 17:44

Re: Problème d'installation de Windows XP

Message par levend »

Et de le recevoir :D .

J'ai retrouvé un vieux PC qui démarre mais il n'as pas de dd et c'est pas facile de retrouver un dd IDE de nos jours, bon de toute façon c'était un P3 500MHz et il me faut au minimum 1GHz donc je n'ai pas insisté.
C'est plus sur mon Athlon XP 3200+ que je veux insister mais j'ai testé deux carte mère et ça ne donne rien, c'étaient des cartes mères achetées d'occaz pour remplacer la mienne qui avait grillé à l'époque à cause d'un mauvais refroidissement.
En principe j'ai une config complète mais je n'arrive pas à mettre la main dessus, elle était dans le boitier que j'ai utilisé il y a quelques temps pour monter ma dernière config, plus actuelle.

Avatar de l’utilisateur
Ryu_wm
Messages : 5441
Inscription : ven. 12 janv. 2018 17:44
Localisation : Pont l'Abbé d'Arnoult (17)

Re: Problème d'installation de Windows XP

Message par Ryu_wm »

Sinon tu restes sur la config d'origine tu nous fais une photo de l'erreur écran bleu et toutes les photos que tu peux de ton bios.

levend
Messages : 7833
Inscription : ven. 12 janv. 2018 17:44

Re: Problème d'installation de Windows XP

Message par levend »

J'avais fait une photo mais je ne l'avais pas postée :D :
Screenshot blue screen XP
Screenshot blue screen XP
212439.jpg (232.19 Kio) Consulté 2839 fois

Avatar de l’utilisateur
Ryu_wm
Messages : 5441
Inscription : ven. 12 janv. 2018 17:44
Localisation : Pont l'Abbé d'Arnoult (17)

Re: Problème d'installation de Windows XP

Message par Ryu_wm »

Ha ?
Il me semblait qu'un écran bleu du à un problème de disque (ahci) donnait "IRQ NOT LESS OR EQUAL"
Mais peux me tromper ... mais là ça viendrait pas de ça.

Mais en cherchant sur le net, no boot device, donc bien un probleme d'IDE potentiellement

https://www.google.com/search?client=fi ... 0x0000007B

levend
Messages : 7833
Inscription : ven. 12 janv. 2018 17:44

Re: Problème d'installation de Windows XP

Message par levend »

J'ai retrouvé la config complète dont je parlais il y a 2 jours, elle était installé dans ma baie, mais pas encore en service (d'ailleurs je vais revoir le contenu de ma baie) et elle n'a pas de port parallèle donc inadaptée.
Cet après-midi j'ai trouvé comment réaliser un miracle : un bon coup de pied et le PC de ma CNC a ressuscité :D, la CNC a donc pu tourner une partie de l'après-midi.
Le problème que j'ai c'est que je ne sais pas pourquoi il ne fonctionnait pas et donc je ne sais pas pourquoi il s'est remis à fonctionner. Je ne suis pas sûr que ma méthode un peu barbare fonctionnera la prochaine fois.
Pour le moment je mets l'autre PC de côté mais je vais tout même cherché à comprendre pourquoi je n'arrive pas à installer XP, on ne sait jamais.

Avatar de l’utilisateur
Zedoune
Messages : 14694
Inscription : ven. 12 janv. 2018 17:44

Re: Problème d'installation de Windows XP

Message par Zedoune »

l'erreur 0x000007B c'est un soucis de drivers sata / ahci

Je m'en souviens, elle m'a traumatisé :pt1cable:

Répondre